aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml27
1 files changed, 27 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..dc0a102
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,27 @@
+[project]
+name = "srtfilter"
+version = "0.1.0"
+authors = [
+ { name="Arjun Satarkar", email="me@arjunsatarkar.net" },
+]
+requires-python = ">=3.12"
+readme = "README.md"
+classifiers = [
+ "Programming Language :: Python :: 3",
+ "License :: OSI Approved :: MIT License",
+ "Operating System :: OS Independent",
+]
+dependencies = [
+ "click==8.1.*"
+]
+
+[project.scripts]
+srtfilter = "srtfilter.srtfilter_cli:main"
+
+[project.urls]
+Homepage = "https://github.com/arjunsatarkar/srtfilter"
+Issues = "https://github.com/arjunsatarkar/srtfilter/issues"
+
+[build-system]
+requires = ["hatchling"]
+build-backend = "hatchling.build"